Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
t222 Wind Transducer comm issue
06-15-16, 10:14 PM
Post: #1
t222 Wind Transducer comm issue
I ordered a T222, although it says model T210. I wanted to add it to my raymarine wireless system. I got it synced and talking. Then I had issues with the remote and had to replace it and had to auto-network the remote and all gauges in and did that except forgot the t222 at the top of the mast. So then brought it down a month or two later and re did the auto-network again trying to add it and an additional dual maxi. All networked except the t222 wind transducer. How do you open it to check the battery as I cant get anything from the t222 wind transducer. Or am I doing something wrong in the auto-network process.
Find all posts by this user
Quote this message in a reply
06-24-16, 11:13 AM
Post: #2
RE: t222 Wind Transducer comm issue
Welcome to the Raymarine Forum riosbornejr,

Q1: I ordered a T222, although it says model T210.
A1: The T222 is part number of the masthead transducer, while T210 is the part number of the Maxi display. As long as you have both of these items, you would then have the required items to display wind.

Q2: How do you open it to check the battery as I cant get anything from the t222 wind transducer. Or am I doing something wrong in the auto-network process.
A2: Given the symptoms, it is believed that the T222 has suffered a failure rather than battery depletion and should accordingly be sent to Raymarine’s Product Repair Center to be serviced.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us