Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Troubleshooting 5s analog radar scanner
07-30-16, 01:34 PM
Post: #1
Troubleshooting 5s analog radar scanner
My system includes networked E120 classic MFDs (with SW version 5.69) and a 4kW 5S open array analog radar scanner. Several weeks ago during a fishing trip I noticed no returns when I enabled the radar which up until now had worked fine. Scanner antenna is rotating as it had previously. Tried adjusting gain and other settings without success. Removed, cleaned, inspected and reassembled cable connections, again with any change.

Can anyone provide troubleshooting ideas?

Are there specific screens in the E120 MDF to help troubleshooting ?

thanks,
Mike
Find all posts by this user
Quote this message in a reply
08-01-16, 12:59 PM
Post: #2
RE: Troubleshooting 5s analog radar scanner
Hello Miked,
Just so you are aware Raymarine no longer supports or repairs analog radar.
That being said you have an E-Classic MFD running the latest software, so if the end result is your radar is defective, the good news is you can upgrade to any current wired Raymarine Digital or HD Radar.
To trouble shoot:
If the scanner does count down to standby and then allows you to transmit, please make your active page a radar page, then set your range to 3nm.
After that press: Menu--->System Diagnostics--->External Interfaces--->Scanners Along the bottom of the page of the soft keys it will state "Self Test Result" press that soft key and look for anything that states "failed" or "Not Tested".
Then after that, perform the same button presses, along the bottom of the page of the soft keys it will state "Operation" press that soft key and then press "Radar Debug On" and look for the details that are listed in the upper left hand corner of the screen. Also in denoting these values, please make sure that the CT and FT values are not oscillating, only the SS value should be oscillating. If the CT and or the FT values are oscillating, the issue is within the radar core.
The SS value should typically be 100 +/- 20% at lower ranges and 130 +/- 20% at higher ranges. If the SS value is low or 0, then again the issue is in the radar core.
If there is a cable test fail, please use the following:
To check the cable you would disconnect the radar cable from the back of the display and measure the ohms resistance according to the information attached to this thread. If you see an open or some way off reading then go to the scanner at check directly on the radar pins for the same readings. If you get the reading, then you have a bad cable, if you still don't get the readings then the scanner is at fault. I have attached the radar cable test to this thread.


Attached File(s)
.pdf  cable resistances1.pdf (Size: 45.15 KB / Downloads: 485)
Find all posts by this user
Quote this message in a reply
03-06-17, 10:17 PM (This post was last modified: 03-07-17 10:43 AM by Chuck - Raymarine - Moderator.)
Post: #3
RE: Troubleshooting 5s analog radar scanner
Hi,
I wanted to document the successful repair of my radar.
1. Ohm'ed the cable and determined it was OK.
2. Troubleshot per the above procedure and with the SS=0, decided to dig into the core further.
3. On boat disassembly disclosed that one of the transformer thru [censored] leads on the modulator PCB ( R58057) had penetrated the insulation sheet and was shorting to the enclosure.
4. Located a new R58057 on ebay in Spain. Acquired at low cost partially due to fortuitous trip to Europe by a work colleague.
5. Reinforced insulation sheet, replaced modulator PCB - radar is now functioning per spec.
( that digital radar will have to wait...)
thanks,
Deepend Mike
Find all posts by this user
Quote this message in a reply
03-07-17, 10:44 AM
Post: #4
RE: Troubleshooting 5s analog radar scanner
Mike,

We're glad to learn of your successful repair. Thanks for sharing.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us