Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ITC-5 Transducer led status
10-23-17, 11:01 AM
Post: #1
ITC-5 Transducer led status
Hello,
I have an ITC-5 connected to a I70s and a depth transducer P319 which was originally connected to a ST60+ depth display.
I removed the ST60+ and connected the transducer to the ITC-5, the transducer status led on the ITC-5 keeps blinking like nothing is connected to the depth terminal.
The boat is out of the water so I can't see any depth reading on the I70s, only tree dashes.
When I touch the face of the transducer, under the boat I can feel it is working.
Should the transducer light on the ITC-5 become steady when the boat is on the water?
Is there any way to find out if everything is connected and running as it should, before putting the boat on the water?

Thank you
Find all posts by this user
Quote this message in a reply
10-25-17, 10:48 AM (This post was last modified: 10-25-17 10:48 AM by Chuck - Raymarine - Moderator.)
Post: #2
RE: ITC-5 Transducer led status
Welcome to the Raymarine Forum kechikan,

Q1. Should the transducer light on the ITC-5 become steady when the boat is the water?
A1. Yes. Please click here to view a FAQ addressing this subject. Until sensed data is present, the iTC-5 LED's will flash. In the case of a speed/temp transducer, speed must be sensed. In the case of the latter, the change may be observed by having someone monitor the iTC-5's LEDs while having another spin the transducer's paddlewheel.

Q2. Is there any way to find out if everything is connected and running as it should, before putting the boat on the water?
A2. The only thing which one may do is to verify whether the iTC-5 is communicating with the i70/i70S MFID to ensure that the iTC-5 is listed among the SeaTalkng devices (MENU->SET-UP->DIAGNOSTICS->ABOUT SYSTEM).
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us