Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[CA11] ST-60 wind
01-02-19, 02:57 PM (This post was last modified: 01-02-19 03:01 PM by Chuck - Raymarine - Moderator.)
Post: #1
[CA11] ST-60 wind
I have a set of ST60 instruments, about 17 years old. The wind transducer is the earlier version with the trapezoidal shaped (if that is the right word) speed cups. The direction vane now is frozen into position (basically pointed forward) and won't break loose, even in big (30 knot) gusts.

It looks like my options are trying to fix the issue, or going with a new transducer, the R 28170 model. I don't fancy going up and down the mast repeatedly (or paying someone to do it) to resolve this.

Related question: if I install a new R28170 transducer, but use my existing base, it looks like I may need to remove a molded "key" that is used on the current model, in order to fit my older base, which does not have the keyway. Is the key hard to remove? How do I do it?

Thanks. Looking forward to getting this resolved.

Pete
Find all posts by this user
Quote this message in a reply
01-02-19, 03:27 PM (This post was last modified: 01-02-19 03:27 PM by Chuck - Raymarine - Moderator.)
Post: #2
RE: [CA11] ST-60 wind
Welcome to the Raymarine Forum Pete,

Indeed the R28170 Masthead Only would be purchased to replace the currently installed wind transducer. The same keyway is used with the current transducer. Accordingly, it should only be necessary to unscrew the locking collar and unplug the currently installed transducer from its base and then plug in the R28170 Masthead and secure it in place with its locking collar.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us