Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[JH11] DS500X
09-01-19, 09:36 PM (This post was last modified: 09-04-19 09:22 AM by John - Raymarine - Moderator.)
Post: #1
[JH11] DS500X
Today my DS500X would not power up. All other electronics work. The Raymarine Auto Helm display in the lower helm shoes the depth. But the chart plotter doesn't show the depth. Clearly something is still collecting depth data, but no longer delivering it to the chart plotter. Not sure how to diagnose the fish finder issue. Read it might be the cord. Any advice would be appreciated.
Find all posts by this user
Quote this message in a reply
09-04-19, 09:52 AM (This post was last modified: 09-04-19 09:53 AM by John - Raymarine - Moderator.)
Post: #2
RE: [JH11] DS500X
This sounds like you have more then one depth source on board. The first step to identifying where your depth is coming from is letting us know all of the electronics on board.

For the DS500X you can check that it is still receiving good voltage at its power connection. Then you can check the voltage on the pins of the cable when removed from the unit. If you see a voltage on the connection to your power and on the pins then something has failed inside you fishfinder. The pin out for the connector can be seen below.

[Image: attachment.php?aid=3529]


Attached File(s) Thumbnail(s)
   
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us