Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[LW11] ITC-5, Depth Transducer
09-06-19, 06:36 AM (This post was last modified: 09-06-19 08:35 AM by Louise - Raymarine - Moderator.)
Post: #1
[LW11] ITC-5, Depth Transducer
Hi,

I recently added an i70s and ITC-5 to my system, which previously consisted of ST60 Speed, ST60 Depth and i60 Wind.

I have connected the Speed and Wind transducer cables to the ITC-5 and am successfully receiving that data on STNG and ST1.

However, whilst I get Depth data on ST1 with the transducer connected to the ST60 Depth, when I connected the transducer cables to the ITC-5 instead I couldn't get any Depth data on STNG or ST1, and the i70s did not show the ITC-5 as a source for Depth.

Is it possible that my depth transducer is compatible with the ST60 but not with the ITC-5? I think it is a pretty standard Airmar one. Anything else I should try? There was a big magnet clipped on to the depth transducer cable, what does that do?
Find all posts by this user
Quote this message in a reply
09-11-19, 04:24 AM
Post: #2
RE: [LW11] ITC-5, Depth Transducer
Dear 9203R,

Thank you for your post.

What transducers do you have? Are they separate transducers or do you have a triducer?

When the depth transducer is connected to the iTC-5, what are the indicator LEDs flashing or displaying?

The analogue ST60 depth transducer is compatible with the iTC-5. I believe the 'magnet' you are referring to is a suppression ferrite to reduce any interference from RFI or EMI.

You confirm you get depth on your ST60 instrument when directly connected?

Many Thanks
Louise
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us