Raymarine forum

Full Version: C90W - Does not power up - buttons flash only
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
My c90w will not power up, the screen does not turn on at all. When pressing the power button the buttons on the right will just flash 3 times.

I'm afraid I fried the thing as I now realize I was feeding it multiple power sources. I recently hooked the c90w to a ST60 via a Seatalk to SeaTalkNG adapter. The ST60 was receiving power via it's original power connection, and the c90w was getting power from it's own power source. This setup worked for a few weeks, and now it just flashes when the power button is pressed.

I tried unhooking the SeaTalkNG connection, but the behavior does not change.

I tried powering the c90w off a powered SeaTalkNG system and nothing happens at all in that configuration.

Any suggestions are much appreciated.
Hello natesms,

I would recommend checking that the fuse for it has not blown. If is still does not power up I would recommend contacting a Raymarine Dealer for assistance, https://www.raymarine.com/buy/find-a-dealer.html

Reference URL's