Raymarine forum

Full Version: No Track with Garmin MFD after Updating Evolution AP
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4
After updating my Evolution Autopilot to latest firmware, track mode did not work with Garmin MFD anymore. The autopilot asks to confirm the next waypoint persistently.

I downgraded to older firmware and everything works again.
Welcome to the Raymarine Forum John,

When operating in Track mode, Raymarine autopilots will not automatically turn onto a route's next course line upon entering the arrival circle of a route's waypoint. For safety purposes, Raymarine's autopilots required acknowledgement (TRACK) that it is safe to turn onto the next course line when entering the arrival circle of a routes next waypoint. Please click here to view a FAQ addressing this subject. Should the problem which you are seeking assistance within not be addressed by this response, then please respond accordingly.
Thanks Chuck, but you misunderstood me.

With old autopilot firmware I have to acknowledge each waypoint once. So it works as intended before updating.

But after update 2.17 the autopilot demands acknowledgement of the same waypoint again and again. When I press the OK button, it is always popping up the same question again after about 1 sec.

Given the reported symptom, it is recommended that you examine the autopilot's diagnostics to verify that all of the autopilot components have been properly updated. These include:
EV-1/2 Sensor Core: v2.17
p70/p70R: v3.06
ACU100/ACU200/ACU300/ACU400: v2.17

If so, then it would be recommended that a log be generated from traffic on the SeaTalkng/NMEA 2000 backbone when following a route and arriving at a waypoint. If supplied with the SeaTalkng/NMEA 2000 log, a problem report may be generated to seek correction of the problem. Should you not have a Raymarine MFD, a Certified Raymarine Installer may be contacted to generate a log for you. Please additionally indicate whether this symptom was introduced with the latest Evolution autopilot software update.
Chuck, thank you for your superfast response.

Yes, I also updated my ACU200 and p70R to latest release.

I do not have a Raymarine MFD installed on the boat permanently. But I own an old A50D which I can plug to the backbone (for updating my autopilot components). Is it possible to create a N2k log using the A50D?

As I mentioned in my first post, the problem was introduced with latest firmware update. If I revert to CCU 1.11, ACU 1.12, p70 2.17 there is no problem anymore.

The A-Series Classic MFDs indeed have the ability to log SeaTalkng data. The command sequence to access the SeaTalkng buffer is MENU->SYSTEM DIAGNOSTICS->EXTERNAL INTERFACES->SEATALKNG; BUFFER. There you will find an option to record (to a compatible CF memory card) SeaTalkng communications. Upon receiving the log, a problem report will be generated noting that the problem does not occur with CCU 1.11, ACU 1.12, p70 2.17 software.
Thanks Chuck,

I logged two test runs in track mode:

One using CCU 2.17, ACU 2.17, p70 3.06 and the other using CCU 1.11, ACU 1.12, p70 2.17. I also made videos of the trips. You can see in the videos that the autopilot operates correctly with old firmware but not with the new one.

Please find logs and videos here:

I hope this helps finding the bug.
I can confirm this exact use case. I have the following set up:
EV-200 setup using a P70 head, Garmin 740s MFD use for navigation and also a a65 that I use for "Data" "Sailing" wind info, all at the helm of my Nonsuch 354 sailing vessel. Everything is NMEA 2000 connected and an Airmar 200WX WeatherStation connected as is a ST1 to STNG converter and ST60 stack for depth/temp/wind.
With Rel 14, everything worked outstanding: when a route was selected on the 740 MFD and the "Track" soft button selected, the P70 requested an initial approval of a turn to meet the course, then would stay silent and do its thing until the next waypoint, when it asked for permission to turn at that way point, all the way to the destination. Perfect.
After downloading 17.45 and installing using the a65, I recommissioned the EV-200 as required, started a 13 mile journey during which was informed that the the magnetic adjustment was satisfactory performed.
The use case is exactly as described: The AP worked outstanding (MUCH tighter course than before) EXCEPT every 1 to 15 seconds the "Advance Waypoint" screen would ask for permission to "Turn to Waypoint X" [yes] [no].

A problem report has been logged accordingly to seek correction of the problem within a future software update. Given the information provided to date, it is recommended that those having interfaced a Garmin chartplotting product as a NMEA 2000 spur to the backbone not update the Evolution autopilot software beyond CCU 1.11, ACU 1.12, p70 2.17 until more is known on this subject.
Thanks, Chuck, for the prompt response and problem report. We'll look for a future update with a fix...
Pages: 1 2 3 4
Reference URL's