Raymarine forum

Full Version: Vesper not talking over seatalk ng
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi Chuck,

I have hooked a Vesper 8000 AIS to my system via SeaTalk ng, using a DeviceNet adapter cable, but the GPM-400/G120 does not see the unit or receive AIS data.

I have tried connecting the vesper both to the Seatalkng hub using a spur cable, and using a t connector with terminator. In both cases, I was able to get the compact keyboard to connect, but not the AIS. I also checked the system diagnostics to see what ng devices were connected, but only the keyboard is seen.

I've updated the firmware on the GPM 400 to 4.66, the firmware in the vesper, rebooted everything, but nothing seems to work.

Any suggestions would be much appreciated.
Welcome to the Raymarine Forum weisbergj,

Please click here to view a FAQ addressing this subject. The items within the referenced FAQ addressing NMEA 0183 networking may be skipped. It is recommended that you verify that the Data Master GPM400 (rather than a repeater GPM400) has been interfaced to the SeaTalkng backbone. Unlike the MFD designs which followed the G-Series GPM400, the SeaTalkng diagnostics of the GPM400 is quite limited. Should the other items listed within the FAQ be satisfied and should these products be interfaced to one another via a powered and properly terminated SeaTalkng / NMEA 2000 backbone, then it would be necessary to interface a NMEA 2000 network analyzer (ex. Actisense NGT-1-USB w/NMEA Reader software, etc.) to determine whether the AIS data is present on the backbone.
Thanks (again) Chuck.

I've gone through the relevant steps, and it seems like there is no data being transmitted or received by the master GPM400 over NMEA2000 -- not just AIS data. The Vesper isn't receiving any NMEA2000 data from any of the devices (MFD, sounder, etc.).

I feel like I'm missing some setting or configuration :(

There are no configuration settings which need to or can be made to the GPM400 to enable / disable the GPM's SeaTalkng/NMEA 2000 communications other than the Data Master configuration setting. When a GP400 is configured as the system's Data Master, then its SeaTalkng/NMEA 2000 port will be activated. However, when a GP400 is configured as the system's Data Repeater, then its SeaTalkng/NMEA 2000 port will be deactivated.
Hi Chuck,

It turns out that the problem was the SeaTalk ng network was hooked into the wrong GPM-400. When the cable was moved to the other GPM-400 (presumably the master), everything worked fine. Looks like it came that way from the factory.

Also, this solved the keyboard beeping issue that I posted in another message.
Glad to learn of the success ... as had been suggested within my initial response, should the Data Master MFD not have been interfaced to the SeaTalkng backbone, then no SeaTalkng / NMEA 2000 communications will occur.
Right, I think the confusion came from which GPM was the master......
You're welcome.
Reference URL's