MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
Raymarine forum - Radar Problem

Raymarine forum

Full Version: Radar Problem
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have twin e120's with an open array radar M92654-s. I have been experiencing issues with the radar, but it is very inconsistent. 2 things could happen when powering up. One, the radar does not move, or it moves at an extreme speed. When at the extreme speed, the radar is picking up objects and seems to work. I have had the boat for 8 years and have not seen that until this year. Just got back from a 9 day trip and it worked flawlessly. Raymarine thought it might be a bad modulator board.
Welcome to the Raymarine Forum Tug Captain,

While such symptoms are rarely encountered, the problem is typically associated with a gearbox assembly failure (the gearbox assembly includes the electrical motor ... the suspected failing component). While Raymarine has officially specified that radar pedestals of this family can no longer be serviced by Raymarine’s Product Repair Center, should the problem be limited to the gearbox assembly, then it may be repaired, as the gearbox is one of the few parts remaining within Raymarine's inventory for the subject open array pedestal. Accordingly, it is recommended that the pedestal be sent to Raymarine’s Product Repair Center to be bench checked / serviced.
Reference URL's