Raymarine forum

Full Version: MFD will not recognize radar
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Installed my eS MDF and Quantum radar this weekend.

Thought the radar install would be easy as there are only two cables.

Radar mounted on my pole perfectly and I ran the power and data cables to the nav area. Plugged the data cable into the eS and wired the radar to the distribution panel (15A circuit breaker with 5A inline fuse). MFD will not recognize radar. All connections are good.

What troubleshooting steps should I follow?

First is making sure of the correct software in the eS MFD. What software level is in the display? The button presses to check, from the home screen, Setup>Maintenance>Diagnostics>Select Device, a list of equipment will come up and show software level of the eS. It needs to be at the latest software level v16.47.
I'll give that a try but the eS is brand new. I've only had it in my possession for a couple of months.

Assuming it is the latest, what would be next?
Software is first check, and is most likely your issue.
You guys were correct! Updated the software version and all is well. Thanks for your help!
You're welcome.
I'm haveing the same issue now. Where or how would I find the correct software?
Hello Seahorse,
Depending on the model of your MFD, the software can be found on our software updates page of Raymarine's web site. The latest software version is V17.45 for our current line of MFD's.
I found this thread troubleshooting my issue. I have a raymarine C127 and the HD Color dome radar. I purchased both around the same time in 2016. The radar worked originally, but then stopped working. The MFD is not recognizing it. The radar has power but when I plug the network cable from the radar into the network switch, no communication light comes on the network switch, and the MFD does not pick it up. I unplugged the network cable from the network switch and plugged it straight into the back of the MFD and still no recognition. if I try to power on the radar from the MFD, the MFD tries to power the radar up but eventually gives me "no radar source found" message. If I unplug the power cable from the radar port and plug it back in, the MFD shows that the radar is booting up, but once that's complete, we go back to "no radar source found". Could the radar be bad or could the cable be bad? I just uploaded the latest software update last evening (version 19) but it didn't change anything. Thanks

Thanks for the providing the results from the troubleshooting performed thus far.
Please click here to view a FAQ addressing this subject. Should you have additionally connected the vessel to shore power, permitted its batteries to be fully charged, and that after the vessel's batteries have been fully charged and while the vessel is still connected to shore power, tested the radome again, and the problem persisted, then radome should be sent to Raymarine’s Product Repair Center to be bench checked / serviced.
Pages: 1 2
Reference URL's