Raymarine forum

Full Version: [DG11] No SOG
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
No SOG displayed after start up
I have a ST60+ system with some additions

ST60 Wind speed & direction (2002) (new masthead transducer installed 2014)
ST60 Close hauled (2002)
ST60 Tri-data (2002)
ST6000+ Auto Pilot (2002)
Graphic display (2010)
AIS 500 (2010) with supplied dedicated gps antenna
E90W MFD (2010) with original (2002) Raystar 120 gps* (new battery installed 2018)
Lifetag system (2010)
Radar 4KW 24” radome (2010)

All above were installed by Raymarine main agents in UK

*This gps antenna was originally fitted to the yacht when she was new, and used with an original RL radar/plotter display

Until recently for many years everything worked fine, then after sailing out no SOG on the MFD or anywhere. COG always showing.
I tried restart gps but I do not think that is the problem, and anyway since changing the gps battery the position acquisition is very fast.

I tried switching off the system then on again and eventually (although maybe not as a result of the switch on/off) , the SOG appears.

Any ideas?

Thank you.
Hi Michael,
Thank you for your enquiry.

It sounds very much like the issue is with the GPS antenna, check there is no SOG anywhere else in the network, for example the EWide display or the graphic display.

Temporarily isolate the EWide and the GPS, still the same issue? if yes, then the GPS is faulty; if no, then there is an issue elsewhere in the network where the data is becoming corrupted. Check the NMEA connection from the AIS500 to the EWide, disconnect to isolate the AIS500, still the same issue?

Using a simple trial and error method, if with all ancillary equipment disconnected the issue still remains, then the GPS is faulty.


Reference URL's