MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
Raymarine forum - [LW11] ITC-5, Depth Transducer

Raymarine forum

Full Version: [LW11] ITC-5, Depth Transducer
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,

I recently added an i70s and ITC-5 to my system, which previously consisted of ST60 Speed, ST60 Depth and i60 Wind.

I have connected the Speed and Wind transducer cables to the ITC-5 and am successfully receiving that data on STNG and ST1.

However, whilst I get Depth data on ST1 with the transducer connected to the ST60 Depth, when I connected the transducer cables to the ITC-5 instead I couldn't get any Depth data on STNG or ST1, and the i70s did not show the ITC-5 as a source for Depth.

Is it possible that my depth transducer is compatible with the ST60 but not with the ITC-5? I think it is a pretty standard Airmar one. Anything else I should try? There was a big magnet clipped on to the depth transducer cable, what does that do?
Dear 9203R,

Thank you for your post.

What transducers do you have? Are they separate transducers or do you have a triducer?

When the depth transducer is connected to the iTC-5, what are the indicator LEDs flashing or displaying?

The analogue ST60 depth transducer is compatible with the iTC-5. I believe the 'magnet' you are referring to is a suppression ferrite to reduce any interference from RFI or EMI.

You confirm you get depth on your ST60 instrument when directly connected?

Many Thanks
Louise
(09-11-19 04:24 AM)Louise - Raymarine - Moderator Wrote: [ -> ]What transducers do you have? Are they separate transducers or do you have a triducer?

Separate transducers for Wind, Speed and Depth. Need to check the exact model.

(09-11-19 04:24 AM)Louise - Raymarine - Moderator Wrote: [ -> ]When the depth transducer is connected to the iTC-5, what are the indicator LEDs flashing or displaying?

If I remember correctly, no LEDs, but I will check again

(09-11-19 04:24 AM)Louise - Raymarine - Moderator Wrote: [ -> ]The analogue ST60 depth transducer is compatible with the iTC-5. I believe the 'magnet' you are referring to is a suppression ferrite to reduce any interference from RFI or EMI.
Thanks.

(09-11-19 04:24 AM)Louise - Raymarine - Moderator Wrote: [ -> ]You confirm you get depth on your ST60 instrument when directly connected?

Yes, depth was and is reading correctly on the ST60 when directly connected to the transducer

Thanks!
Dear 9203R,

Did you check the iTC-5 for the LEDs?

Please email me at support.uk@raymarine.com if you have any further queries.

Many Thanks
Louise
Reference URL's