Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
RL70C not communicating with RC631
03-13-16, 02:42 PM
Post: #1
RL70C not communicating with RC631
Hello,

On my 2003 Sailboat new to me

I have at the nav station:

RL70C Radar Plus = Says Raymarine on boot - V2.09
ST60 Tridata
ST60 Wind
400G Course Computer
ICOM IC-502

At mast
Raymarine Radome - not sure which one it is but is 24" dia.

At the helm

RC631 Plus chart plotter = Says Raymarine on boot - V3.2
ST6001+ Autopilot head
GPS Head not sure which one but is original

At companionway
ST60 Wind
ST60 Depth
ST 60 Speed

Questions:
First the RL70 and RC631 are connected via seatalk and HSB2. both work fine independently, however, I believe that these two units should be able to share chart and radar screens via the HSB2. However I cannot get this to happen. About the only thing they seem to share are the cursors. Meaning RL70 cursor shows on RC631 and the RC631 cursor shows on RL700. But that is it, no chart or radar sharing.

All the other data is shared on the seatalk network. If I switch the c-map card between units I can get charts on one or the other. However when it's in the RL70 I cannot get the radar to overlay on the chart.

How do I trouble shoot this?

If I can't get them to share chart and rader then I may plan on upgrading the radar and MFD displays. i.e. new radome and MFd's at nav and helm
But I would like to keep all the ST60's, 400G course computer and ST6001+. From what I can dechiper I will need to mate the seatalk with the seatalkng, is that correct? What other considerations?

Lastly, which autopilot control head would replace the ST6001 and still keep the course computer and the other autopilot peripherals?

Thanks
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
RL70C not communicating with RC631 - dkritter - 03-13-16 02:42 PM

Forum Jump:


User(s) browsing this thread: 2 Guest(s)

Contact Us