Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
C70 display , No heading available w/ alarm
07-17-18, 10:57 PM
Post: #2
RE: C70 display , No heading available w/ alarm
Hello 1compassrose,

It sounds like you have two different, probably unrelated problems: the rotary encoder control, and your Seatalk network.

The Seatalk network problem is what's causing the 'No Heading' alarm on the C70 and the pilot problem. This is usually some form of cabing problem, but could also be caused in this case by a pilot problem (so the pilot causes the 'No Heading' error rather than the other way round.) The simplest explanation is that there's a restricted supply voltage to the pilot for the amount of current it's drawing (e.g. worn drive motor drawing more current or corroded or loose terminals restricting the the supply), which browns-out the processor of the pilot and causes the loss of heading data on the C70.

The C70's getting on a bit now and spares are getting very limited but you may be able to its rotary encoder repaired through your local service centre, but that almost certainly won't address the Seatalk issue.

In what way specifically does the pilot shut down? Completely power off, stay powered by drop to Standby, or something else?

Regards,
Tom

Raymarine since 1999.
Interests: Diagnosis of problems in sonar/fishfinders, NMEA2000, ethernet comms, autopilots, thermal cameras
Location: Sydney, Australia.

Please don't PM me asking for direct support, please ask a public question instead so that others can see the question and answer. Forum posts will always be answered before PM requests.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
RE: C70 display , No heading available w/ alarm - Tom - Raymarine - Moderator - 07-17-18 10:57 PM

Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us