Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[CA11] ST70 Head control not keeping basic parameters
12-17-19, 07:58 PM (This post was last modified: 12-18-19 11:21 AM by Chuck - Raymarine - Moderator.)
Post: #1
[CA11] ST70 Head control not keeping basic parameters
My ST70 HEAD CONTROL works perfectly, as it controls correctly the autopilot.
However, Everytime I power it up, it shows the welcome screen where you need to choose the language, boat type and units.
The other parameters are kept (like all autopilot parameters).
Is there an internal battery that needs to be changed ?
Find all posts by this user
Quote this message in a reply
12-18-19, 11:32 AM (This post was last modified: 12-20-19 08:56 AM by Chuck - Raymarine - Moderator.)
Post: #2
RE: [CA11] ST70 Head control not keeping basic parameters
Welcome to the Raymarine Forum Korrigan,

ST70 autopilot control heads contain no end user serviceable part and the design of Raymarine products is considered to be proprietary. This is typically a symptom of very old software within the autopilot control head. The currently installed version of software may be determined via the ST70 autopilot control head's Diagnostics menu. It is recommended that currently installed version of software within the ST70 autopilot control head and course computer both be determined, and if found to not be the latest, that the software within these products be updated with the latest available Raymarine product software updates. Should your system not feature a MFD which is capable of updating the software within these products, then please click here to view a FAQ addressing alternative means of updating the software within these products.
Visit this user's website Find all posts by this user
Quote this message in a reply
12-20-19, 02:35 AM (This post was last modified: 12-20-19 08:46 AM by Chuck - Raymarine - Moderator.)
Post: #3
RE: [CA11] ST70 Head control not keeping basic parameters
Thank you for the answer. I have to precise that the setup have been working great together for a year or so before showing this issue. I don't have any MFD on my setup.
Display version: 1.06
Pilot model ID: E1219
Pilot Software version: 1.19
Find all posts by this user
Quote this message in a reply
12-20-19, 08:56 AM (This post was last modified: 12-20-19 08:57 AM by Chuck - Raymarine - Moderator.)
Post: #4
RE: [CA11] ST70 Head control not keeping basic parameters
Korrigan,

As indicated within my initial response, ST70 autopilot control heads contain no end user serviceable part and the design of Raymarine products is considered to be proprietary. Our repair technicians have recommended that the software with the control head and autopilot course computer be brought up to the latest available versions:
- ST70 autopilot control head: v3.04
- SPX autopilot course computer: v3.05

Please click here to view a FAQ addressing options for updating software within these components within systems lacking a compatible MFD which is capable of updating the software within these components. Should the problem persist, then it would be recommended that the ST70 autopilot control head be sent to Raymarine’s Product Repair Center to be bench checked / serviced. As indicated within the referenced FAQ, the ST70 autopilot control head's software may be updated by Raymarine’s Product Repair Center.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us