Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
No satellite data and STLK Fail message on auto pilot
07-28-16, 05:32 AM
Post: #1
No satellite data and STLK Fail message on auto pilot
Good morning,

A couple of weeks ago, I lost satellite data on my C80 and the message STLK fail appeared on my Auto Pilot (ST6001). I contacted Raymarine support and was told to change the battery and update the software on the C80.

Since then, I have:

- Changed the battery in the C125 for a NC battery

- Re-secured all my connections

- Removed the C80 from my boat and installed it on a friends boat who as a set up similar to mine. On his boat, I did get satellite signals.

- I ordered a new C125 thinking that it my unit was the defective device. Installed yesterday, no change. Still no satellite signals and STLK Fail on my auto Pilot.

Prior to changing the batttery in the C125, the entire line on menu/GPS(I believe) was not accesible. Since changing the battery, the ON is light up and everything else is dark. I can not reset the antena.

The next step I plan on trying is to change the entire cable coming from the GPS antena and going to the C80.

If anyone can help me out, I would greatly appreciate it.

Thanks in advance.
Find all posts by this user
Quote this message in a reply
07-28-16, 12:50 PM
Post: #2
RE: No satellite data and STLK Fail message on auto pilot
Welcome to the Raymarine Forum mbiciola,

Please note that c125 is the product name for a 12 inch Raymarine Multifunction Display belonging to a group of MFDs commonly referred to as the a/c/e/eS/gS-Series MFDs. Is it possible that you have incorrectly identified the product which you have referred to as a C125?
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us