Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
RS125 Connected to e120 MFD
10-24-17, 08:57 PM
Post: #1
RS125 Connected to e120 MFD
I have two e120 MFD displays with a Raystar RS125 receiver connected via SeaTalk, which has been connected without modification for 12 years. Last year due to slow start up I replaced the battery in the receiver and it has worked well for the past year until recently. Today I had a flashing red light and no fix on MFD. After several tries through normal start up and shut down, I turned the power off to the MFD to create a hard shutdown. After several minutes the MFD finally received a fix and trying it several times afterward through normal shut down it appears to work normal. Could this have been caused by a failed battery in the receiver or should I look elsewhere if it happens again?
Find all posts by this user
Quote this message in a reply
10-25-17, 09:28 AM
Post: #2
RE: RS125 Connected to e120 MFD
Welcome back to the Raymarine Forum Mike,

The reported issue may indeed be caused by something as simple as a depleted CR2032 battery within the RS125. However, should replacement of the sensor's battery not address the problem and should sensor's LED continue to be illuminated red (vs amber or green), then it would indicate that the RS125 has failed and would need to be replaced. Please click here to view a FAQ addressing how the RS125 may be replaced with a RS150 GPS Sensor.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us