Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[DG11] ST50 shortcut?
12-22-18, 01:48 PM (This post was last modified: 12-24-18 08:35 AM by Chuck - Raymarine - Moderator.)
Post: #1
[DG11] ST50 shortcut?
I have a range of ST50 instruments (speed/log, wind, vmg, compass/steering). Depth counter is ST60. The speed/log has encountered an issue. The display had the backlight on, and was showing weird figures, alternating with speeds from 0 to 2,5 knots while the boat speed was over 6 knots. Simultaneously, my charge controller was showing that quite a lot of amperes were being drawn. So I suspect there is a shortcut current somewhere in the system. After I had took power off the instruments on my switchboard, and turned it back on a couple of minutes later, the bug did not reappear. I suspect it was because it switched to default setting: backlight off.

How do I troubleshoot?

Or should I replace the unit? Is it possible to just replace with a new i60?
Find all posts by this user
Quote this message in a reply
01-02-19, 09:11 AM
Post: #2
RE: [DG11] ST50 shortcut?
HI LaurensenKitty

Thankyou for your enquiry,

If you can isolate the ST50 Speed display and can replicate the issue, then the recommended option is to replace the ST50 display with an i50 display.

The link, please click here , covers replacing an ST50 Wind with an i60 Wind display, but the same applies to replacing an ST50 Speed with an i50 Speed. Note that the ST50 Depth/ Speed/ Tridata displays are replaced with i50 digital displays and the st50 Wind is replaced with the i60 analogue wind display.

Regards
Derek
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us