Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Autohelm ST50 Wind Instrument
05-06-16, 03:03 PM
Post: #1
Autohelm ST50 Wind Instrument
I've set up an STng circuit to tie together an e7 MFD, P70/ACU100/eV1/ST4000+ Autohelm, and AIS650. Using an ST to STng converter, I've connected an i40 Bidata speed and depth instrument and an old Autohelm ST50 Wind instrument. I've updated software and done initial startup of the e7 MFD and Autohelm system. Everything seems to be running well except the i40 and ST50 wind instrument won't turn on (blank screens). I have verified the ST to STng converter is supplying 12V to the ST50 at the right hand ST connector (when looking at the back of the instrument). The i40 Bidata Speed/Depth instrument is connected to the left hand ST connector on the back of the ST50 instrument. Voltage coming out of the ST50 at the left hand ST connector is 4.27 VDC, probably not enough to engergize the i40 unit.

Questions:
1. Is the ST50 capable of supporting the i40 Bidata unit? If so, am I looking at a failed ST50 Head (The unit was working well before I installed the new equipment)
2. If there is no obvious fix for the ST50 setup, I would consider looking for a used ST60 Wind Instrument display unit or a new i60 Wind display unit (which would tie in with STng leaving the i40 Bidata alone on the ST to STng converter) because it appears they would work with my existing masthead unit. Can you confirm that these two instrument heads should work with the masthead unit installed with the ST50?
Find all posts by this user
Quote this message in a reply
05-09-16, 10:34 AM
Post: #2
RE: Autohelm ST50 Wind Instrument
1. You should be able to support 12 VDC from the Seatalk connection from the ST50. It does point toward and issue with the ST50 display.

2. Unfortunately the ST50 masthead is not compatible with the ST60/+ or the current i60 instrument displays. You will have to upgrade both the display and masthead unit. They are the same wiring colors, but the calibration perimeters are not the same and therefore are not compatible.
Find all posts by this user
Quote this message in a reply
05-11-16, 12:18 AM
Post: #3
RE: Autohelm ST50 Wind Instrument
(05-06-16 03:03 PM)LngTmSlr Wrote:  I've set up an STng circuit to tie together an e7 MFD, P70/ACU100/eV1/ST4000+ Autohelm, and AIS650. Using an ST to STng converter, I've connected an i40 Bidata speed and depth instrument and an old Autohelm ST50 Wind instrument. I've updated software and done initial startup of the e7 MFD and Autohelm system. Everything seems to be running well except the i40 and ST50 wind instrument won't turn on (blank screens). I have verified the ST to STng converter is supplying 12V to the ST50 at the right hand ST connector (when looking at the back of the instrument). The i40 Bidata Speed/Depth instrument is connected to the left hand ST connector on the back of the ST50 instrument. Voltage coming out of the ST50 at the left hand ST connector is 4.27 VDC, probably not enough to engergize the i40 unit.

Questions:
1. Is the ST50 capable of supporting the i40 Bidata unit? If so, am I looking at a failed ST50 Head (The unit was working well before I installed the new equipment)
2. If there is no obvious fix for the ST50 setup, I would consider looking for a used ST60 Wind Instrument display unit or a new i60 Wind display unit (which would tie in with STng leaving the i40 Bidata alone on the ST to STng converter) because it appears they would work with my existing masthead unit. Can you confirm that these two instrument heads should work with the masthead unit installed with the ST50?
Find all posts by this user
Quote this message in a reply
05-11-16, 12:23 AM
Post: #4
RE: Autohelm ST50 Wind Instrument
(05-09-16 10:34 AM)Steve - Raymarine - Moderator Wrote:  1. You should be able to support 12 VDC from the Seatalk connection from the ST50. It does point toward and issue with the ST50 display.

2. Unfortunately the ST50 masthead is not compatible with the ST60/+ or the current i60 instrument displays. You will have to upgrade both the display and masthead unit. They are the same wiring colors, but the calibration perimeters are not the same and therefore are not compatible.

REPLY:
I've ordered a new i60 Wind system with standard transducer and cable. To make sure I understand you correctly, I shouldn't have to replace the cable (unless it is defective). Did I understand you correctly? Thanks for your help.
Find all posts by this user
Quote this message in a reply
05-12-16, 02:49 PM
Post: #5
RE: Autohelm ST50 Wind Instrument
Yes, the ST50 Masthead base can connect to the current Masthead transducer, so the masthead base and cable does not have to be changed out.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us