Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[CA] [CA11] Axiom Pro not recognizing external GPS
01-29-20, 10:18 AM (This post was last modified: 01-29-20 02:01 PM by Chuck - Raymarine - Moderator.)
Post: #1
[CA11] Axiom Pro not recognizing external GPS
I have an Axiom Pro 12 MFD running software 3.11.42. I also have an i70s, p70, and a Maretron GPS200 NMEA2000 GPS device. Both the i70s and p70 are updated to the current software version.

When originally installed about a year ago the Axiom, i70s and p70 could see the Maretron on the NMEA network. Over the last year the Maretron failed and I had everything use the Axiom GPS. Now that I've replaced the Maretron with a new unit the i70s and p70 can see the Maretron but the Axiom does not see the Maretron.

Any idea why?

Thank you
Find all posts by this user
Quote this message in a reply
01-29-20, 02:39 PM (This post was last modified: 02-07-20 08:55 AM by Chuck - Raymarine - Moderator.)
Post: #2
RE: [CA11] Axiom Pro not recognizing external GPS
Welcome to the Raymarine Forum Rick,

When systems feature more than one source of GPS, GPS Datum, Date & Time, wind, depth, speed, etc. it is sometimes necessary (and considered to be a best practice) to use the Data Sources feature of the i70/i70S (preferred), p70/p70R/p70S/p70RS, or Data Master MFD to manually specify which source will be used by the system. As inferred, data source selection need only be performed on one device within the system and because the i70/i70S MFIDs and p70/p70R/p70Sp7RS autopilot control heads are among the quickest devices to complete booting, it is generally considered to be a best operational practice that the data source selection be performed by one of the system's i70/i70S MFIDs or p70/p70R/p70Sp7RS. Should the Data Sources feature of the Data Master MFD not list the Maretron GPS Sensor, then please respond accordingly.
Visit this user's website Find all posts by this user
Quote this message in a reply
01-29-20, 03:44 PM (This post was last modified: 01-29-20 04:26 PM by Chuck - Raymarine - Moderator.)
Post: #3
RE: [CA11] Axiom Pro not recognizing external GPS
Your last statement is correct. The Data Sources feature of the Data Master MFD does not list the Maretron GPS Sensor. The i70 and p70 both list the Maretron. I can choose the Maretron as the GPS source from either the i70 or p70 and that choice propagates to the p70 or i70 but not to the MFD.

I was going to bring this up in another post but perhaps it's related.

I've been using the internal GPS as the GPS data source for all devices.

When we select a point on the chart to "goto" the MFD will stop the "goto" feature at random points. This is true if we are navigating to a waypoint or simply select a point on the chart. If we are using the autopilot and have it navigate to the point, the autopilot will indicate that it's "completed" the navigation. The autopilot will continue on it's course.

I have not submitted this as I've not captured the scenario in a clear manner where I can document exactly what happened. This frequently happens when someone else is on watch or by the time you realize you are no longer "going to" the waypoint there's no information about what happened.

We are in port in Mazatlan Mexico for the next week. We then depart for Puerto Vallarta. I was hoping to capture the exact scenario on that passage.

So perhaps this is all related? Are there error logs I can download from the MFD?

Thank you,
Find all posts by this user
Quote this message in a reply
01-29-20, 04:45 PM (This post was last modified: 02-07-20 08:54 AM by Chuck - Raymarine - Moderator.)
Post: #4
RE: [CA11] Axiom Pro not recognizing external GPS
Rick,

Verify that the backbone features two (and only two) termination plugs. Test the resistance across each termination plug's CAN_H and CAN_L pins ... 120 Ohms should be measured. Verify that the backbone has been powered from a single spur socket which is located at the approximate midpoint of the backbone's LEN load and has been powered via a SeaTalkng Power Cable. If an ACU200, ACU300, or ACU400 has been installed, please verify that the ACU's SeaTalkng power switch has been switched OFF (the second power insertion may result in a ground loop). Inspect the Backbone Cables used to connect the MFD's spur socket to the rest of the backbone for damage, splices, or modifications ... replace if damage is found. Inspect the Spur Cable used to connect the MFD's spur socket to the backbone for damage, splices, or modifications ... replace if damage, splices, or modifications found. Disconnect and reconnect the spur connections to the Data Master MFD's NMEA 2000 connector and the spur cable's connection to the backbone, being certain to ensure that all locking rings are moved to the locked position. Verify whether the MFD's networked devices list (HOME->SETTINGS->NETWORK->) includes all other devices within the network. If the system's other SeaTalkng / NMEA 2000 devices are not listed, then it may indicate a failure within the MFD's NMEA 2000 communications circuitry if the above have all been satisfied. If only the Maretron GPS is found to be missing from this list, then the MFD's internal GPS should be configured OFF and the LightHouse 3 NMEA 2000 recording feature (HOME->SETTINGS->NETWORK->DIAGNOSTICS->NMEA DEVICES & MESSAGES->NMEA MESSAGES; RAW DATA->ENABLE; START RECORDING) should be used to record 15-20 seconds of data. The resulting NMEA 2000 log should then be attached to this thread for further analysis.
Visit this user's website Find all posts by this user
Quote this message in a reply
02-04-20, 01:47 PM (This post was last modified: 02-04-20 02:24 PM by Chuck - Raymarine - Moderator.)
Post: #5
RE: [CA11] Axiom Pro not recognizing external GPS
Thank you for the detailed instructions.

The power switch on the ACU400 was in the OFF position. I tested both terminators and are both 120 ohms. Checked all connections and moved the power source from one side of approximately the center to the other side of approximately the center. All the cables are in good shape.

I'm attaching two files, one is the complete device list which includes the Maretron GPS200 which has a name of "3.0" which I'd say is odd. The serial number for the GPS device contains the string "GPS200".

I'm also including the log file you requested. In the log file viewer on the MFD I can see COG and other navigation related messages from device 3.0 so the MFD can "see" the messages. For some reason it doesn't list the device as a source of GPS data.

Thanks for your help.


Attached File(s)
.log  nmea2000_20200204_18.log (Size: 200.08 KB / Downloads: 97)
.json  Diagnostics_Device_List.json (Size: 6.05 KB / Downloads: 93)
Find all posts by this user
Quote this message in a reply
02-04-20, 02:53 PM (This post was last modified: 02-07-20 08:54 AM by Chuck - Raymarine - Moderator.)
Post: #6
RE: [CA11] Axiom Pro not recognizing external GPS
Rick,

Thanks for the requested diagnostic information. A problem report will be logged accordingly.

One last question: Forgetting the Data Sources feature, if the MFD's internal GPS sensor is switched OFF, the MFD is then switched OFF, and then the MFD is switched ON again, does the MFD report having a GPS position FIX after approximately 6 minutes (the maximum amount of time that I would expect the Maretron GPS to require)?
Visit this user's website Find all posts by this user
Quote this message in a reply
02-04-20, 05:26 PM (This post was last modified: 02-05-20 09:00 AM by Chuck - Raymarine - Moderator.)
Post: #7
RE: [CA11] Axiom Pro not recognizing external GPS
Hi Chuck,

Wierdest thing... I did that and now the GPS Fix screen shows a position and at the top of the screen has the label "GPS200 via STng(32)". So it's getting it's position from the Maretron. I then went back to the screen to select the GPS data source and it does not list any potential data sources.

So it's seeing the data from the Maretron, and using it, but won't list it as a source. Now that I'm poking around the diagnostic page I see that I can select a device from the NMEA devices page then select NMEA messages. I can see the messages from the Maretron so it must be working as the MFD wouldn't display a message it can't understand.

So I guess I can run like this for the short term. It would be nice to be able to select the Maretron as a GPS source from the NMEA setup page.

I kept playing around with the diagnostic tools which are very cool and discovered that my Digital Yachts AIT2000 class B AIS trasnponder is also providing GPS data on the network. If I disable the Maretron and the internal GPS then it gets it's position from the AIT2000. The AIT2000 does not show up as a potential source of GPS position data on the MFD either. Looking at the NMEA messages in the diagnostic tool it's putting out COG, Position, SOG.

Why doesn't the Digital Yacht device show up as a potential source? If it was just the Maretron then I'd think maybe Maretron is doing something incorrectly but Digital Yachts and Maretron both have pretty good reputations so I'm wondering if there's a problem in the MFD? Especially since the MFD can see and display the messages, just can't specify one of the two as a GPS source.

Thanks for your patience and help, this has been very educational.
Rick
Find all posts by this user
Quote this message in a reply
02-05-20, 09:37 AM
Post: #8
RE: [CA11] Axiom Pro not recognizing external GPS
Rick,

Thanks for the confirmation and additional testing. When I had looked at the networked devices list, I had a suspicion that there may be a conflict between the GPS output of the third party Class B AIS transceiver and the Maretron GPS sensor. That said, the problem report will include information concerning the workaround suggested to supply the system with GPS data. As most Class B AIS transceivers do not (at least not by default) transmit GPS data to a N2K backbone or via NMEA 0183, you may want to consider configuring the third party Class B AIS transceiver to not transmit GPS data to a N2K backbone until this issue has been investigated by Raymarine's engineering team.
Visit this user's website Find all posts by this user
Quote this message in a reply
02-06-20, 06:50 PM (This post was last modified: 02-06-20 08:15 PM by Chuck - Raymarine - Moderator.)
Post: #9
RE: [CA11] Axiom Pro not recognizing external GPS
Hi Chuck,

I reached out to Digital Yachts tech support to figure out how to disable the broadcast of GPS data on the network and quickly received a technical bulletin from 2015 describing the precise problem I'm seeing. They were puzzled because they thought it only occurred under limited circumstances and believed it had been resolved by Raymarine a few years ago.

I'll attach the technical bulletin.

So now I've disabled the GPS in the MFD and silenced the broadcast of GPS data from the AIS receiver. The only device on the network is the Maretron GPS receiver and we're leaving town tomorrow morning. We'll be out of cell range for a couple of days and sailing a total of 72 hours, almost all on autopilot. We'll see if the problem goes away.

-Rick


Attached File(s)
.pdf  Tech 00064-2015 AIT2000+AIT3000 Inhibit NMEA2000 GPS data .pdf (Size: 349.56 KB / Downloads: 159)
Find all posts by this user
Quote this message in a reply
02-07-20, 08:54 AM
Post: #10
RE: [CA11] Axiom Pro not recognizing external GPS
Rick,

Thanks for the additional information.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)