Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[DG11] Test ITC-5
03-15-20, 02:34 PM (This post was last modified: 03-16-20 03:57 PM by Chuck - Raymarine - Moderator.)
Post: #1
[DG11] Test ITC-5
I got a ITC-5 and an Airmar Tri sensor for speed/depth/temp. Since my boat is quite some miles away I did a dry run test at home.
I connected the sensor to the ITC-5 according to colours, put two terminators in the back bone connectors and a power supply to the spur connector.
I expected the LED status indicators for speed, depth and SeatalkNG to show a solid green light, the others to show intermitted pulse (since no sensors connected). However what I get is a solid light for SeatalkNG indicator, all others are off.
Then I disconnected the transducer (so no sensors at all). Again staus for SeatalkNG ok, all other LEDs off. Does this indicate a defect for the ITC-5?
Find all posts by this user
Quote this message in a reply
03-18-20, 08:18 AM (This post was last modified: 03-18-20 08:23 AM by Derek - Raymarine - Moderator.)
Post: #2
RE: [DG11] Test ITC-5
Hi bertl
Thankyou for your enquiry.

Please check the screen/ shield wire is only connected to the depth connections, and not to the speed as per the attached drawing

Also note that if the depth is not locking on to the bottom or the speed paddlewheel has not been spun the itc-5 will not recognise a transducer is connected.

try spinning the paddlewheel and check you can hear the depth ticking.
regards
Derek


Attached File(s)
.pdf  iTC-5-and-DST-800-Connection-instructions-EN.pdf (Size: 281.96 KB / Downloads: 76)
Find all posts by this user
Quote this message in a reply
03-19-20, 05:08 AM (This post was last modified: 03-19-20 07:34 AM by Chuck - Raymarine - Moderator.)
Post: #3
RE: [DG11] Test ITC-5
Hi Derek,
thank's for your answer. The transducer is wired as shown on your attachment.
According to the manual in case the ITC-5 doesn't recognice the transducer then the related status LED should flash.
Also all the other status LEDs for Wind, Compass etc should flash since no sensors are connected.

My question is: Why is none of the sensor status LEDs showing any signal (except the SeaTalk LED, solid green)?

The ITC-5 does have power. I measured 8V between sheeld and red.
Find all posts by this user
Quote this message in a reply
03-24-20, 11:30 AM
Post: #4
RE: [DG11] Test ITC-5
Dear bertl,

Thank you for your post.

I recommend sending the iTC-5 in to our service department for testing, you can book this in via the website here.

Many Thanks
Louise
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)