Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Trouble with SeaTalk connectors
05-11-20, 09:11 AM (This post was last modified: 05-13-20 08:17 PM by Jules - Raymarine - Moderator.)
Post: #1
Trouble with SeaTalk connectors
I am having a new problem with SeaTalk ng connectors. I have plugged/unplugged these connectors previously with no problems whatsoever, but in the process of installing a new system with some new/longer backbone cabling I have had a helluva time with unplugging newly installed cabling from my 5-way connectors and T-connectors. They install easily enough, and the system has even ops checked good, but when disconnecting those same connections they simply won't pull out no matter what. Perhaps I should carefully lubricate the small o-rings on the cable connector end before inserting? If so, wondering if there is a recommended lubricant or process? This is all I can figure to do. Thanks for any advice! A search of the internet for similar complaints came up with nothing...

David
Find all posts by this user
Quote this message in a reply
05-13-20, 08:30 PM
Post: #2
RE: Trouble with SeaTalk connectors
Hi tyed,

Yes the STng connectors are very tight in their sockets to make them weatherproof and this makes them difficult to disconnect as the O-ring material ages and becomes a little less flexible.

Never lubricate rubber or plastic with any petroleum based products as they will damage the material. Only use Lanolin or Silicon grease making sure there are no solvents in it that are petroleum related. A light smear of Lanolin on the STng connector will make it easier to extract and also reduce the chance of pin corrosion.

Happy boating

Kind regards
Jules
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)