Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[DG11] St60 and itc5
05-11-20, 01:45 PM (This post was last modified: 05-13-20 11:55 AM by Derek - Raymarine - Moderator.)
Post: #1
[DG11] St60 and itc5
Hi, I am having a bit of trouble finishing this. The goal was to expand my system. Now it is just to get the original ST60 displays to work again.

The ST60s and the AP(SG2) worked just fine until I put the ITC5 in. Now the speed doesn’t register. I didn’t think too much as it was on the hard. However after launch, it still does not work with the ITC5. Getting annoyed, I plugged in the compass to the ITC5, now it and the depth work, but the wind and speed flash where before it was just speed flashing.

I read somewhere that the flash could be because of a ground? To take a jumper from a working instrument to the non-working? I will try that later.

The AP has been OFF this whole time. I am going to remove the compass transducer. At that point:

Q1 why are two out of three working fine? Should jumper the -0v from the speed to the wind?

Q2 why did introducing the compass make the wind flash?

Q3 I will remove the Axiom and terminate at the ITC5, then it should be just like when it was working before the ITC5 and SeaTalk converter sending the signal to the these daisy chained displays, right?

The only other thing is there is a data running from the AP Display/head back to the SG2. It was/is powered by the other displays, but no data until the SG2 is powered on. Since it is dead until the SG2 is powered, I am ignoring it.

Diagram attached. Thanks, Joel
Find all posts by this user
Quote this message in a reply
05-13-20, 12:00 PM
Post: #2
RE: [DG11] St60 and itc5
Hi Joel,

Thanks for the enquiry,

best to rewind a bit, the compass sensor should always be connected to the autopilot course computer, the S2G need sthe compass direct connected to work correctly.

I am guessing from your diagram that the seatalk is powered as it the STng, so you need to cut the red core in the Yellow seatalk wire to the converter because you are powering the converter both through the SeaTalk and through the STng and this is not allowed under the NMEA2000 rules.

Cut the red core leaving just te tyellow and the screen connected between the SeaTalk part of the system and the Converter. the converter then will only take its power from the STng backbone.

Now check the status of the LEDs in the itc5, when the depth is pinging, the wind anemometer is spinning and the speed paddlewheel is spinning, you should see solid green leds next to the transducers plugged in to the itc-5.

Thanks
Derek
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)