Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ST60+ Compass - Recurring Display Problem
08-13-17, 12:53 PM
Post: #1
ST60+ Compass - Recurring Display Problem
I have an ST60+ Compass in which there is a recurring problem -- displaying dashes, no course. Volt/Ohm test failed to identify problem and I wired new power because this was the last of four instruments in the daisy chain.
One thing I have not tried yet is to cut the full length transducer cable and crimp on new terminals. It's full length so has more resistance, and the excess is coiled, which might not be a good thing for compass data.
Any other ideas?
While looking for a replacement, it now appears that Raymarine no longer sells any displays for compass transducers. Is this correct?
Too bad, because a compass provides an indicator of leeway when heading is compared to GPS COG.
Find all posts by this user
Quote this message in a reply
08-16-17, 02:40 PM
Post: #2
RE: ST60+ Compass - Recurring Display Problem
Welcome to the Raymarine Forum,

Q1. Any other ideas?
A1. Please click here to view a FAQ addressing how one may test the fluxgate transducer.

Q2. While looking for a replacement, it now appears that Raymarine no longer sells any displays for compass transducers. Is this correct?
A2. Not quite correct. While Raymarine does not currently offer any instrument displays to which an analog fluxgate compass may be directly interfaced, it would be possible replace the ST60 compass with an i70S which is mated to an EV-1 Sensor Core. Should the i70S be interfaced to the SeaTalk bus (via a SeaTalk to SeaTalkng Converter) to which any other SeaTalk devices have been interfaced then the i70S would not only be capable of displaying heading, but many of the other data items present on the SeaTalk bus.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)