Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
tacktick t121 issue
08-17-17, 11:21 AM
Post: #1
tacktick t121 issue
I inherited a tacktick system with my boat and I hooked it all up the other day and the hull transmitter is not connecting to my display unit. I left it to charge overnight and nothing happened. I figured it was the battery so I took the hull transmitter apart and removed the batteries carefully and have 2 more on order now. The inside looked clean and in good shape, is there anything else that could potentially be causing the hull transmitter to act dead other than the batteries if it looks to be in good nick?
Find all posts by this user
Quote this message in a reply
08-17-17, 01:09 PM (This post was last modified: 08-17-17 01:09 PM by Chuck - Raymarine - Moderator.)
Post: #2
RE: tacktick t121 issue
Welcome to the Raymarine Forum Nick,

There's nothing else which may be done until the a new battery has been installed within the hull transmitter. Should the problem persist after having received/installed the new battery, then the hull transmitter should be sent to Raymarine’s Product Repair Center to be bench checked / serviced.
Visit this user's website Find all posts by this user
Quote this message in a reply
08-17-17, 01:15 PM
Post: #3
RE: tacktick t121 issue
ok thanks, here's hoping!
Find all posts by this user
Quote this message in a reply
08-17-17, 01:40 PM
Post: #4
RE: tacktick t121 issue
You're welcome.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)