Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[DG] ST6000 installation
08-18-18, 07:54 AM (This post was last modified: 08-20-18 08:03 AM by Derek - Raymarine - Moderator.)
Post: #1
[DG] ST6000 installation
Hi

I am looking to complete the installation on my 28 year old boat, which I bought a couple of years ago and which hasn't been in the water yet. It came with Autohelm instruments all unused and in their boxes, ST6000 pilot system and linear drive unit along with ST50 wind, depth, speed control heads and transducers.

I have bench tested the kit and all works fine except the pilot system, where I get a read out stating "No Link" . I believe I have wired everything up correctly as per the diagram. So can anyone help with a diagnosis here please? I have attached a photo to show the arrangement with the read out on the bench.

thanks
Mark


Attached File(s) Thumbnail(s)
   
Find all posts by this user
Quote this message in a reply
08-20-18, 08:15 AM
Post: #2
RE: [DG] ST6000 installation
Hi Minimage

Thank you for your enquiry.

NO LINK indicates that the control unit has no comms with the course computer, it could be a sign that the entine SeaTalk network has crashed or just that there is a fault with the Autopilot.

Start by disconnecting everything from SeaTalk other than the St6000 control head and keep this wire as short as possible, check there are no shorts or stray wires to the SeaTalk connections.

If the fault disappears when the other equipment is connected, then gradually reconnect the other units until the fault reoccurs, this will then identify the faulty unit or cable.

If the fault remains when the autopilot is isolated, then there is a fault with the control unit or with the course computer, spares for this age of product are few and far between, you could return it to one of our approved service dealers, but even so, it may even be unrepairable.

regards
Derek
Find all posts by this user
Quote this message in a reply
08-24-18, 12:47 PM
Post: #3
RE: [DG] ST6000 installation
Hi Derek,

Thanks for your reply and help with my issue.

Unfortunately the fault remains when the autopilot is isolated so it looks like the fault is with the control unit or the course computer.

regards
Mark
Find all posts by this user
Quote this message in a reply
08-28-18, 11:10 AM
Post: #4
RE: [DG] ST6000 installation
Hi Minimage,

The only way to resolve between the ST6000 control unit and the computer is to swap out a test control unit, otherwise, send both to the nearest Raymarine repair shop.
Regards
Derek
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)