Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[CA] [CA11] DST800 to iTC-5
04-09-19, 06:53 PM (This post was last modified: 04-10-19 02:33 PM by Chuck - Raymarine - Moderator.)
Post: #1
[CA11] DST800 to iTC-5
I have an Airmar DST800 with Speed and Temp connected to an iTC-5. Temp is connected OK although the Speed is not connected (green led flashing)
I have tested the Speed via the Green wire and Shield and the circuit opened and closed the required 4 times in a complete turn of the paddle wheel. Would this indicate that the iTC-5 is faulty. It is still covered by warranty.
Find all posts by this user
Quote this message in a reply
04-10-19, 02:40 PM (This post was last modified: 06-03-19 07:53 AM by Chuck - Raymarine - Moderator.)
Post: #2
RE: [CA11] DST800 to iTC-5
Welcome to the Raymarine Forum jmur2808,

Should each of the DST800's lead be interfaced to the iTC-5, the transducer's paddlewheel be spun through several quick revolutions, and the Speed/Temp LED of the iTC-5 continue to blink, then it would appear that the iTC-5 or the DST800 has suffered a failure. Please click here to view a FAQ addressing how to test the speed transducer. Should no fault be found with the speed transducer, then the iTC-5 should be sent to Raymarine’s Product Repair Center to be bench checked / serviced.

Most Raymarine products, including the iTC-5, carry a 2-year warranty from the date of purchase (product or boat) which may be extended to a 3-year warranty if the product is registered within 30 days or installed by a Certified Raymarine Installer or OEM boat builder. If seeking information concerning the warranty status of your product, then it would be recommended that Raymarine's warranty team be contacted by e-mail (warranty@raymarine.com).
Visit this user's website Find all posts by this user
Quote this message in a reply
06-01-19, 11:54 PM (This post was last modified: 06-03-19 07:54 AM by Chuck - Raymarine - Moderator.)
Post: #3
RE: [CA11] DST800 to iTC-5
Attachments.


Attached File(s)
.pdf  jmur2808 Network 2.pdf (Size: 74.83 KB / Downloads: 200)
.pdf  jmur2808 Network 1.pdf (Size: 776.77 KB / Downloads: 189)
Find all posts by this user
Quote this message in a reply
06-03-19, 07:51 AM
Post: #4
RE: [CA11] DST800 to iTC-5
jmur2808,

It is unclear why you have added the attachments to this thread. If seeking confirmation that the backbone appears to have been properly constructed, then please be aware that it does indeed appear to be properly constructed. Please see my initial response regarding the iTC-5, how to test it in conjunction with a speed transducer, and what to do if the expected results are not observed.
Visit this user's website Find all posts by this user
Quote this message in a reply
07-05-19, 07:00 PM (This post was last modified: 07-15-19 10:55 AM by Chuck - Raymarine - Moderator.)
Post: #5
RE: [CA11] DST800 to iTC-5
Apologies re the attachment Chuck, I never got round to posting a reply.
This is a update. I had the 2 x iTC-5's checked by Raymarine and both were OK.
Although I still have the same problem, Temp is OK but the Speed will still not connect to either of the iTC-5's.
The DST800 was installed August 2018 and worked for approx 6 months and then I received a 'Current Limited" error. I then installed an EV1 and ASU400. Everything else in my installation is working correctly and eveything else is visible from both my e127 and i70s.
Speed is greyed out in the i70s and neither can find the iTC-5 to select Speed. They can find the iTC-5 for Temp, Fluxgate compass, Depth and Wind.
The speed test with a meter between the shield and green wire is still OK.

Is there any further assistance that you could offer??

regards
Find all posts by this user
Quote this message in a reply
07-15-19, 05:33 PM
Post: #6
RE: [CA11] DST800 to iTC-5
jmur2808,

The only other thing than I can suggest is to send both the iTC-5 and the DST800's speed/temp insert to Raymarine’s Product Repair Center to be bench checked / serviced.
Visit this user's website Find all posts by this user
Quote this message in a reply
08-18-19, 06:52 PM (This post was last modified: 08-19-19 12:42 PM by Chuck - Raymarine - Moderator.)
Post: #7
RE: [CA11] DST800 to iTC-5
Further update Chuck,
I took both an iTC-5 and the DST800 to Sydney Raymarine and was lucky that the Technician who had checked both of the iTC-5 previously was close to the counter and offered to check the DST800 for me. Within a few minutes he isolated the problem to the Temp. sensor had failed and was not allowing the unit to connect. Installed a new DST800 and all good now with everything now working.

Thanks for your advise.
Find all posts by this user
Quote this message in a reply
08-19-19, 12:42 PM
Post: #8
RE: [CA11] DST800 to iTC-5
You're welcome.
Visit this user's website Find all posts by this user
Quote this message in a reply
11-03-19, 01:43 AM (This post was last modified: 11-03-19 02:11 PM by Chuck - Raymarine - Moderator.)
Post: #9
RE: [CA11] DST800 to iTC-5
Hi Chuck,
Everything is working OK again with the new SDT800 fitted.

My question is that the Speed, Depth, Temo and Wind are all listed as "Internal"
on my e127. Is this normal?

regards Jim
Find all posts by this user
Quote this message in a reply
11-03-19, 02:17 PM
Post: #10
RE: [CA11] DST800 to iTC-5
Jim,

Withint systems featuring an iTC-5, the system must additionally include an i70/i70S MFID. The MFID is in turn used to calculate the instrument depth/speed/temperature transducer and the iTC-5 will be listed as a source associated with depth and speed data within the system. Should the e127 MFD be interfaced to a compatible fishfinder transducer, then an internal source for these data items will listed within the MFD's Data Sources feature.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)